Personal Mobile Banking App

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Nov 08, 2023 - 09:21 EST

Investigating

We are currently experiencing an issue with our Personal Mobile Banking App . Users may receive an error message regarding disk or connectivity issues when attempting to launch. While we work to restore service, you can log into Personal Online banking from the login section on our homepage to access their account information. We apologize for any inconvenience and are working to restore service as quickly as possible.
Posted Nov 08, 2023 - 08:43 EST
This incident affected: Personal Services (Personal Mobile App).