Wire Transfer Services
Incident Report for Hingham Institution for Savings
Resolved
Wire transfer processing has been restored.
Posted Dec 27, 2023 - 12:40 EST
Investigating
We are currently experiencing a system issue that is delaying the processing of outgoing wire transfers. We have engaged our service partners and are working to resolve the issue as quickly as possible. Incoming wire transfers are not impacted by this processing delay and are being posted normally at this time.
Posted Dec 27, 2023 - 11:43 EST
This incident affected: Business Services (ACH/Wire Transfer Services).