Email Alerts
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 16:42 EDT
Identified
We are aware that some customers received an email alert regarding ACH Deposit and Check activity on their accounts. The email alert was generated in error as a result of work to implement new alert tool for Business and Personal Online Banking. The error has been identified and we have taken steps to prevent further emails from being generated at this time. We apologize for any concern these email alerts may have caused and look forward to bringing you an enhanced online banking alert system in early 2023.
Posted Nov 01, 2022 - 09:47 EDT
Investigating
We are aware that some customers have received email alerts regarding transactions on their accounts. We are investigating the issue and will post additional details as they become available.
Posted Nov 01, 2022 - 08:49 EDT