Debit Card Transaction Processing

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Aug 22, 2026 - 12:36 EDT

Investigating

We are experiencing a service interruption causing some debit card transactions to decline. We have engaged our support teams and are actively working to restore full debit card processing as soon as possible. We sincerely apologize for any inconvenience
Posted Aug 22, 2026 - 12:16 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).