The issue with ACH transaction descriptions not showing in the account transaction history has been resolved. All transaction descriptions are now available. We thank you for your patience while we worked to resolve this issue.
Posted Jan 06, 2026 - 15:24 EST
Update
We continue to work to restore the missing ACH transaction descriptions for automatic withdrawals and deposits dated for January 5th. Changes were implemented overnight and anticipate the full transaction details will be available today. Thank you for your patience, while we work with our partners to resolve this issue.
Posted Jan 06, 2026 - 13:39 EST
Update
We continue to work to restore the missing ACH transaction descriptions for automatic withdrawals and deposits dated for January 5th. Changes were implemented overnight and anticipate the full transaction details will be available today. Thank you for your patience, while we work with our partners to resolve this issue.
Posted Jan 06, 2026 - 09:08 EST
Investigating
Update: A fix will be implemented and ACH descriptions will be fully restored by tomorrow morning. We apologize for the delay, and appreciate your patience while we work to resolve this issue. Please contact us if you need immediate assistance.
Posted Jan 05, 2026 - 09:55 EST
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking, Business Mobile App, ACH/Wire Transfer Services).