Account Transaction Processing

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Dec 23, 2025 - 14:35 EST

Investigating

We are currently experiencing an issue that may impact the processing of ACH transactions, specifically automatic withdrawals. We are working with our partners to resolve this issue as quickly as possible and apologize for any inconvenience this issue as causes.
Posted Dec 23, 2025 - 10:37 EST
This incident affected: Personal Services (Account Transfers).