Hingham Savings Debit Cards
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Oct 21, 2022 - 18:25 EDT
Monitoring
We continue to work to resolve the issues impacting our automated phone systems for debit card activation, reporting cards lost or stolen and reporting debit card fraud as well as the My Card feature within our Personal Mobile Banking App. While we work to restore service, please contact our Customer Support Team at 781.749.2200 for assistance. We thank you for your patience and apologize for any inconvenience this issue has caused.
Posted Oct 21, 2022 - 17:36 EDT
Update
We continue to work to restore access to the our debit card activation line and the My Card feature accessible within our Personal Mobile Banking App. For assistance while we work to restore service, please contact our Customer Support Teams at 781-749-2200.
Posted Oct 21, 2022 - 13:53 EDT
Investigating
We are currently experiencing an issue that could impact Hingham Savings Debit Cards. While we work to restore service, please contact our Client Services Team at 781-749-2200 for assistance.
Posted Oct 21, 2022 - 13:01 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards, HIFS My Card App).