Debit Card Transaction Processing Interruption
Incident Report for Hingham Institution for Savings
Resolved
The Mastercard transaction processing incident is now resolved and debit card transactions are processing normally.
Posted Jan 24, 2024 - 16:51 EST
Investigating
We are aware that Mastercard may be experiencing a service interruption that could result in debit card transactions being declined. We are working to resolve the issue as quickly as possible.
Posted Jan 24, 2024 - 16:17 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards).