Winter Storm - Delayed Branch Opening

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 10:58 EST

Identified

Due to the winter storm, our branch locations will open at 10:00 AM on January 26th.

All other business operations, including customer support and payment services, remain open during regular business hours. Please note that Online Banking and Mobile Deposit are available 24/7 for your convenience.
Posted Jan 25, 2026 - 19:41 EST
This incident affected: Locations (Branch Locations).