Business and Personal Mobile Deposits
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 08:50 EDT
Investigating
We are currently investigating an issue with making mobile deposits via our Personal Online Banking, as well as our Business Online Remote Deposit Capture service. We will update once the service has been restored.
Posted May 31, 2022 - 16:09 EDT
This incident affected: Personal Services (Personal Mobile App) and Business Services (Desktop Remote Deposit Capture).