Online Banking Transfers

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 17:08 EST

Investigating

We are investigating an issue that may have prevented some transfers from Personal and Business Online from posting as expected on January 1st, 2026. We are currently working with our partners to resolve this issue as quickly as possible and apologize for the inconvenience this issue has caused.
Posted Jan 06, 2026 - 13:57 EST
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App, Account Transfers) and Business Services (Business Online Banking, Business Mobile App, Desktop Remote Deposit Capture).