Debit Card Transaction Processing

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 11:06 EDT

Update

A resolution has been developed and is scheduled for implementation. We expect a full return to normal service by Monday, July 7th. Until the fix is deployed, some deposit transactions may not be reflected in the available balance for immediate card or ATM use. We apologize for the inconvenience and appreciate your patience.
Posted Jul 06, 2025 - 07:16 EDT

Identified

We have identified an issue causing some deposit transactions to not immediately reflect in the available balance for debit card transactions and ATM withdrawals. This has resulted in some declined card transactions. A resolution is expected by Monday. We apologize for any inconvenience.
Posted Jul 05, 2025 - 21:48 EDT

Update

Out teams continue to work to resolve the issue that is causing dome debit card activity to be declined in error. We sincerely apologize for any inconvenience this issue may cause
Posted Jul 05, 2025 - 18:13 EDT

Update

Our teams continue to work to resolve the issue that is causing some debit card activity to be declined in error. We sincerely apologize for any inconvenience this issue may cause.
Posted Jul 05, 2025 - 16:27 EDT

Update

We are continuing to investigate this issue.
Posted Jul 05, 2025 - 15:21 EDT

Update

Our teams continue to work to resolve the issue that is causing some debit card activity to be declined in error. We sincerely apologize for any inconvenience this issue may cause.
Posted Jul 05, 2025 - 15:21 EDT

Investigating

We are aware of an issue some causing legitimate debit card transactions to be erroneously declined. Our teams are actively working towards a swift resolution. We sincerely apologize for any inconvenience this may cause.
Posted Jul 05, 2025 - 14:13 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).