Personal Online Banking and Mobile App Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 22:38 EDT

Investigating

We are aware of an issue impacting our Personal Online banking services, including our mobile app. Users attempting to log in may receive an error message indicating that we are unable to validate information and to try again. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Apr 13, 2026 - 21:08 EDT
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App).