Bill Payment Incident

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 10:15 EDT

Investigating

We are currently experiencing an issue with the Bill Payment feature in our Personal Online banking services, including our mobile apps. You may encounter a 405 error message when attempting to access this feature. We are working diligently to restore service and apologize for any inconvenience this may cause.
Posted Jun 22, 2025 - 09:21 EDT
This incident affected: Personal Services (Bill Pay Services).