Business Online - Wire Transfers
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jan 28, 2025 - 15:38 EST
Investigating
Clients attempting to send a wire through our Business Online service may receive an error message indicating our systems are unable to retrieve the originator information. We are working with our partners to resolve this issues as quickly as possible and apologize for the inconvenience. Please contact our Cash Management Teams at 781-783-1701 for assistance with any time sensitive payment requests.
Posted Jan 28, 2025 - 14:10 EST
This incident affected: Business Services (ACH/Wire Transfer Services).