eStatements Emails
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 05, 2020 - 17:59 EDT
Identified
We are aware of an issue regarding the eStatements email notification. In order to view current or past eStatements please login to your online banking account. If you have any further questions please contact us at 781-783-1796. Thank you
Posted May 13, 2020 - 16:36 EDT
This incident affected: Personal Services (Electronic Statements).