10/27/2022 Debit Card Outage
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 14:58 EDT
Update
Incident has been resolved
Posted Oct 27, 2022 - 14:57 EDT
Update
We are continuing to investigate this issue.
Posted Oct 27, 2022 - 11:01 EDT
Update
We are continuing to investigate this issue.
Posted Oct 27, 2022 - 11:00 EDT
Investigating
We are experiencing issues impacting our automated phone systems for debit card activation, reporting cards lost or stolen and reporting debit card fraud as well as the My Card feature within our Personal Mobile Banking App. While we work to restore service, please contact our Customer Support Team at 781.749.2200 for assistance. We thank you for your patience and apologize for any inconvenience this issue has caused.
Posted Oct 27, 2022 - 10:38 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).