Business Online - Wire Processing
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted May 23, 2022 - 13:24 EDT
Investigating
We are currently researching an issue in which an error message may be presented when processing online Wire transfers. We apologize for the inconvenience. If your matter is urgent please call the Cash Management Department at 781-783-1701 for assistance.
Posted May 23, 2022 - 11:09 EDT
This incident affected: Business Services (Business Online Banking, ACH/Wire Transfer Services).