Mobile Deposit Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 09:36 EDT

Investigating

We are currently experiencing an issue that is causing users to receive an error message when attempting make a mobile deposit. Users will receive the error after capture the check image and clicking Make Deposit. We are working with our partners to restore services as quickly as possible and apologize for any inconvenience this issue has caused.
Posted Aug 03, 2026 - 09:31 EDT
This incident affected: Business Services (Business Mobile App) and Personal Services (Personal Mobile App).