Remote Deposits for Personal and Business Online Banking
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 16:28 EDT
Investigating
Users attempting to deposits checks through our Personal and Business Mobile Apps or through our Remote Deposit Capture feature of Business Online may experience an error or delays when processing deposits. We are working to restore services as quickly as possible and apologize for the inconvenience.
Posted Jun 04, 2024 - 14:50 EDT
This incident affected: Business Services (Business Mobile App, Desktop Remote Deposit Capture) and Personal Services (Personal Mobile App).