Personal and Business Online Banking Transaction History

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 15:18 EDT

Investigating

We are currently experiencing an issue affecting both our Personal and Business Online banking services. Users are unable to retrieve or view transaction history dated prior to July 1, 2025. Our technology partners are actively working to restore access as quickly as possible and apologize any inconvenience this issue has caused.
Posted Apr 13, 2026 - 12:25 EDT
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking).