eStatements
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 15:38 EDT
Investigating
We are currently experiencing issues when retrieving eStatements in retail and business online banking. We are working to restore full functionality and apologize for any inconvenience. If you need immediate assistance please contact us at 781-749-2200.
Posted Apr 21, 2020 - 15:14 EDT
This incident affected: Personal Services (Electronic Statements).