Zelle Maintenance

Scheduled for Mar 22, 00:00 - 05:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2026 - 14:30 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 18, 2026 - 14:28 EDT

Scheduled

We will be undergoing system maintenance on our Zelle product on March 22nd, 2026 from 12:00AM to 5:00AM. This may cause brief interruptions to occur.
Posted Mar 18, 2026 - 13:20 EDT
This scheduled maintenance affects: Personal Services (Zelle).