We continue to work to restore functionality to the External Transfer feature available through our Personal Online Banking service. All other online services available through Personal and Business Online Banking, including our mobile apps are fully operational at this time.
Posted May 02, 2025 - 11:21 EDT
Update
We continue to work to restore functionality to the Bill Pay and External Transfer features available through our Personal Online Banking service. All other online service available through Personal and Business Online Banking, including our mobile apps are fully operational at this time.
Posted May 02, 2025 - 09:56 EDT
Update
We continue to work to restore functionality to the Bill Pay service available through Personal and Business Online as well as the External Transfer feature available through Personal Online. All other online service available through Personal and Business Online Banking, including our mobile apps are fully operational at this time.
Posted May 02, 2025 - 09:18 EDT
Update
We are seeing improvements in our online channels with access restored to our Personal Online Banking and mobile app as well as wire processing in Business Online. We continue to work to restore service to our Bill Pay and Alert features for both Personal and Business Online Banking.
Posted May 02, 2025 - 09:01 EDT
Update
We are continuing to work to restore access to our online applications. We have successfully restored service to our Business mobile app. However, our Personal mobile app, Personal Online Banking, Bill Pay, and Business Online Online Wire functionality remain unavailable at this time.
Posted May 02, 2025 - 08:36 EDT
Update
We are continuing to work to restore access to our online applications. We have successfully restored ACH functionality within our Business Online application. However, our Personal and Business mobile apps, Personal Online Banking, Bill Pay, and Online Wire functionality remain unavailable at this time.
Posted May 02, 2025 - 07:37 EDT
Investigating
We are currently experiencing an issue with our Personal and Business mobile apps and our Personal Online Banking. We are working diligently to restore service and apologize for any inconvenience this may cause. Our Business Online Banking services, accessible from our website, are operational; however, access to ACH and Wire functionality is limited.
Posted May 02, 2025 - 07:18 EDT
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App, Bill Pay Services, Account Transfers) and Business Services (Business Mobile App, ACH/Wire Transfer Services, Bill Pay).