Business Online Wire Origination Down

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Dec 27, 2022 - 17:13 EST

Investigating

We are currently investigating an issue with our Business Online wire services. Some customers may be receiving an error upon submission that states the originator information is incorrect. We are aware of this issue and working to resolve as quickly as possible.
Posted Dec 27, 2022 - 15:35 EST
This incident affected: Business Services (ACH/Wire Transfer Services).