While we have restored service to ensure the transaction descriptions for electronic activity dated for today is displaying as expected in our digital tools, we continue to work to restore transaction descriptions for yesterday's electronic activity. We thank you for your patience as we work to restore this information and apologize for the inconvenience this issue has caused. Our Customer Experience Team remains available to assist in providing the additional details for any electronic debit activity until service is restored. Our Customer Experience Team can be reached at 781-749-2200.
Posted Dec 10, 2024 - 12:34 EST
Identified
We continue to work with our partners to restore the transaction details for electronic debit activity in our digital tools and anticipate that the full descriptions details will be available tomorrow. We thank you for your patience as we work to restore this information and apologize for the inconvenience this issue has caused. Our Customer Experience Team remains available to assist in providing the additional details for any electronic debit activity until service is restored. Our Customer Experience Team can be reached at 781-749-2200.
Posted Dec 09, 2024 - 15:51 EST
Update
We continue to work with our partners to restore the full transaction description for electronic debit activity in our digital banking tools. Your accounts remain safe and secure and apologize for the inconvenience this issue has caused. Our Customer Experience Team can assist in providing the additional details for any activity while we work to restore service. They can be reached at 781-749-2200.
Posted Dec 09, 2024 - 12:06 EST
Update
We continue to work with our partners to restore the full transaction description for electronic debit activity in our digital banking tools. Your accounts remain safe and secure and apologize for the inconvenience this issue has caused. Our Customer Experience Team can assist in providing the additional details for any activity while we work to restore service. They can be reached at 781-749-2200.
Posted Dec 09, 2024 - 11:04 EST
Investigating
We are aware of an issue impacting the transaction details for electronic debit activity dated for today, Monday, December 9th. Customers accessing their accounts online, will see the description ACH Withdrawal only. We are working with our partners to restore the full transaction description and apologize for any inconvenience this issue has causes. Your accounts remain safe and secure and our Customer Experience Team can assist in providing the additional details for any activity while we work to restore service. They can be reached at 781-749-2200.
Posted Dec 09, 2024 - 10:07 EST
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App) and Business Services (Business Online Banking, Business Mobile App).