Digital New Account Opening Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:14 EST

Update

We continue to work with our partners to restore access to our online account opening platform as quickly as possible. We apologize for the inconvenience and appreciate your patience while we work to restore service.
Posted Nov 18, 2025 - 10:13 EST

Investigating

We are aware of an issue with Cloudflare that is impacting access to some web applications, including our online account opening platform. Uses attempting to open a new checking or savings account online will receive an error message when attempting to reach our site or new account product link. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Nov 18, 2025 - 09:05 EST
This incident affected: Personal Services (Digital Account Opening).