Debit Card Processing Delays

Incident Report for Hingham Institution for Savings

Resolved

Service Update: Issue Resolved. Debit card processing has been fully restored. All systems are operating normally, and transactions should now process without delay. We apologize for the earlier interruption and appreciate your patience.
Posted Jan 27, 2026 - 17:46 EST

Investigating

Service Update: Potential Debit Processing Delays. We are currently investigating reports of a service interruption affecting debit card processing. During this time, some transactions may be intermittently declined. We are working closely with our partners to resolve this and apologize for any inconvenience.
Posted Jan 27, 2026 - 16:22 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards).