Notice of Retail Online and Business Online Incident February 07, 2025

Incident Report for Hingham Institution for Savings

Resolved

Access to our Personal Online, Business Online, and mobile banking applications has been restored. We are monitoring all applications and will provide further updates if needed.
Posted Feb 07, 2025 - 18:07 EST

Investigating

Retail Online and Business Online may be experiencing a service interruption. As a result, users may experience latency when attempting to log into their online or mobile banking application.
Support teams are engaged and working to restore service as quickly as possible.
We will update you as information becomes available or by approximately 5:00 p.m. ET.
Posted Feb 07, 2025 - 16:59 EST
This incident affected: Public Website.