Business Online - ACH and Wire Transfer Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 16:15 EDT

Update

We are continuing to investigate this issue.
Posted Jun 23, 2025 - 15:31 EDT

Investigating

Business Online users attempting to initiate an ACH or wire transfer may receive an error message that Originator Information May Not Be Found or there is a Memo Post Error. We are working with our partners to restore service as quickly as possible and apologize for the inconvenience. For any time sensitive payment needs please contact our Cash Management Group at 781-783-1701 for assistance.
Posted Jun 23, 2025 - 15:17 EDT
This incident affected: Business Services (ACH/Wire Transfer Services).