Online Banking Transfer Posting Issue

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 11:09 EDT

Investigating

We have identified an issue where some online transfers performed on July 4th are not posting to accounts or appear to have been duplicated. We are actively working with our partners to resolve this issue as quickly as possible and apologize for any inconvenience this issue may cause.
Posted Jul 07, 2025 - 08:07 EDT
This incident affected: Personal Services (Personal Online Banking, HIFS Mastercard Debit Cards) and Business Services (Business Online Banking).