ACH Processing and Posting Delay

Incident Report for Hingham Institution for Savings

Resolved

The issue impacting ACH transaction processing and posting has been fully resolved. All delayed ACH transactions have now been successfully processed and are reflected in account balances and transaction histories.
Posted Mar 19, 2026 - 09:08 EDT

Investigating

We are currently experiencing an issue that has delayed the processing and posting of ACH transactions.

As a result, these transactions are not currently reflected in account balances or transaction histories. We have successfully identified the root cause and our technical teams are actively implementing a resolution.

We will provide further updates as the processing resumes.
Posted Mar 19, 2026 - 08:21 EDT
This incident affected: Business Services (ACH Transaction Posting) and Personal Services (ACH Transaction Posting).