Hingham Institution for Savings Website

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:40 EST

Investigating

We are aware of a service outage impacting Cloudflare and a result our website is currently down. We are closely monitoring this incident and are waiting for a resolution from our partners. While out main website is unavailable, our online banking solutions remain fully functional. Users needing to access accounts via a browser can bypass our main website by using the links provided below;

Personal Online Login: https://web1.secureinternetbank.com/PBI_PBI1151/Login/211370370

Business Online Login: https://web1.secureinternetbank.com/EBC_EBC1151/Login/211370370/22

Thank you for your patience as we work to restore service.
Posted Nov 18, 2025 - 08:57 EST
This incident affected: Website (Public Website).