Personal Mobile Banking - Intermittent Access

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Jul 09, 2024 - 19:33 EDT

Investigating

We are currently researching an issue that is resulting in intermittent availability for users attempting to access our Personal Mobile Banking app. While we work to restore service, users can continue to access their account information through Personal Online from our website at www.hinghamsavings.com.
Posted Jul 09, 2024 - 17:04 EDT
This incident affected: Personal Services (Personal Mobile App).