Debit Card Transaction Denials
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted May 19, 2020 - 22:53 EDT
Update
We are continuing to investigate this issue.
Posted May 19, 2020 - 22:00 EDT
Investigating
We are aware of a processing issue that may cause certain debit card transactions to be declined in error. We are working to resolve this issue and apologize for the inconvenience.
Posted May 19, 2020 - 20:57 EDT
This incident affected: Personal Services (HIFS Mastercard Debit Cards).