Personal Mobile Banking App
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 17:32 EDT
Update
We are seeing improvement with access to our Personal Mobile Application. At this time access has been restored for some users, while others may continue to experience issues. We continue to work diligently with our partners to fully restore service to our Personal Mobile Banking Application. We apologize for the ongoing inconvenience this disruption in service has caused. We understand the importance of reliable digital tools for our clients and we are committed to resolving this issue as quickly as possible.
Posted Oct 01, 2024 - 17:12 EDT
Update
We continue to work diligently with our partners to restore service to our Personal Mobile Banking Application. We apologize for the ongoing inconvenience this disruption in service has caused. We understand the importance of reliable digital tools for our clients and we are committed to resolving this issue as quickly as possible.

While we work to restore service, users can follow the steps outlined below to log into Personal Online banking from the login section on our homepage to access account information:
1. Open the device browser (example: Safari or Chrome)
2. Navigate to https://www.hinghamsavings.com/
3. Select Log In/ Enroll
4. Select Personal - Log In
5. Enter username and password to access account information.
Posted Oct 01, 2024 - 16:46 EDT
Update
We continue to work diligently with our partners to restore service to our Personal Mobile Banking Application. We apologize for the ongoing inconvenience this disruption in service has caused. We understand the importance of reliable digital tools for our clients and we are committed to resolving this issue as quickly as possible. While we work to restore service, users can log into Personal Online banking from the login section on our homepage to access account information.
Posted Oct 01, 2024 - 15:32 EDT
Update
We continue to investigate an issue that is causing some users to receive and error when logging in to our Personal Mobile Banking Application. We are continuing to work with our partners to resolve the issue as quickly as possible and apologize for any inconvenience. While we work to restore service, users can log into Personal Online banking from the login section on our homepage to access account information.
Posted Oct 01, 2024 - 14:16 EDT
Update
We continue to investigate an issue that is causing some users to receive and error when logging in to our Personal Mobile Banking Application. We are continuing to work with our partners to resolve the issue as quickly as possible and apologize for any inconvenience. While we work to restore service, users can log into Personal Online banking from the login section on our homepage to access account information.
Posted Oct 01, 2024 - 13:05 EDT
Investigating
We are currently experiencing an issue that may cause some users to receive an error message when accessing our Personal Mobile Banking App . The error message indicates an error has occurred and to call for assistance. While we work to restore service, you can log into Personal Online banking from the login section on our homepage to access your account information. We apologize for any inconvenience and are working to restore service as quickly as possible.
Posted Oct 01, 2024 - 12:11 EDT
This incident affected: Personal Services (Personal Mobile App).