Access to Business Online Banking has been fully restored. We appreciate your patience while we worked to resolve this issue. We apologize for any inconvenience this issue has caused.
Posted Jan 08, 2026 - 13:31 EST
Investigating
We are currently experiencing an issue impacting our Business Online banking service. Users attempting to log into Business Online from our website may receive an error message or experience extreme latency when attempting to log in. We are working with our partners to restore service as quickly as possible and apologize for the inconvenience. While we work to restore service, our Business mobile application remains fully operational for your banking needs. For assistance with Wire Transfers through Business Online, please contact our Cash Management Team at 781-783-1701.
Posted Jan 08, 2026 - 12:54 EST
This incident affected: Business Services (Business Online Banking).