Business Online Wires Down
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Jul 13, 2021 - 11:11 EDT
Investigating
We are currently researching an issue in which an error message may be presented when processing online Wire transfers. We apologize for the inconvenience. If your matter is urgent please call Digital Banking at 781-783-1796 for assistance.
Posted Jul 13, 2021 - 10:40 EDT
This incident affected: Business Services (Business Online Banking, ACH/Wire Transfer Services).