Business Mobile App for Samsung Users
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 17:58 EST
Identified
We are are of an issue impacting our Business Mobile app for users with a Samsung device running certain version of OneUI 6.0. We are working with our partners to restore access as quickly as possible and apologize for the inconvenience. While we work to restore service users can continue to access their account information through Business Online from our website at www.hinghamsavings.com.
Posted Feb 01, 2024 - 10:49 EST
This incident affected: Business Services (Business Mobile App).