Enrolling In E-Statements
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 16:29 EDT
Investigating
We are experiencing an issue enrolling in eStatements for both Personal and Business Online Banking services. We are working to restore service as quickly as possible and apologize for the inconvenience. For immediate needs, please contact the Digital Banking Group at 781-783-1796. Thank you for your patience.
Posted Sep 17, 2021 - 10:19 EDT
This incident affected: Personal Services (Personal Online Banking, Electronic Statements) and Business Services (Business Online Banking).