Personal and Business Online Intermittent Access Issues

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted May 19, 2025 - 16:18 EDT

Investigating

We are currently experiencing intermittent access issues for our Personal and Business Online Banking services. While we work to restore service, our mobile applications remain fully operational for your banking needs. We thank you for your patience and apologize for the inconvenience.
Posted May 19, 2025 - 16:17 EDT
This incident affected: Personal Services (Personal Online Banking) and Business Services (Business Online Banking).