Business Online and Retail Online Banking - Intermittent Availability
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 18:46 EST
Update
We are continuing to investigate this issue.
Posted Mar 03, 2023 - 17:42 EST
Update
We continue to experience intermittent access issues with our Personal and Business Online Banking services. While we work to restore service, our Personal and Business Mobile Banking apps remains fully operational for your banking needs. We thank you for your patience and apologize for the inconvenience.
Posted Mar 03, 2023 - 17:41 EST
Update
We are continuing to investigate this issue.
Posted Mar 03, 2023 - 17:40 EST
Investigating
We are currently experiencing intermittent access issues with our Business Online Banking and Retail Online Banking services. Our mobile applications remain fully operational for your banking needs. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Mar 03, 2023 - 16:51 EST
This incident affected: Personal Services (Personal Online Banking).