Personal and Business Online Bill Pay Outage

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Feb 16, 2025 - 09:03 EST

Update

Users may continue to experience errors when attempting to access the Bill Payment feature in our Personal and Business Online Banking services, including our mobile apps. We apologize for any inconvenience and appreciate your patience as we continue working to restore full service.
Posted Feb 16, 2025 - 08:44 EST

Investigating

We are currently experiencing an issue with the Bill Payment feature in our Personal and Business Online banking services, including our mobile apps. You may encounter an error message stating that the feature is unavailable or that your session has timed out. We are working diligently to restore service and apologize for any inconvenience this may cause.
Posted Feb 16, 2025 - 07:43 EST
This incident affected: Personal Services (Bill Pay Services) and Business Services (Bill Pay).