Retail and Business Apps down
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 11:59 EST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2019 - 11:58 EST
Investigating
We are experiencing intermittent issues with both our Personal and Business Mobile Apps. Our online banking service is available in the meantime. We are working to restore service as quickly as possible and apologize for the inconvenience. Thank you for your patience.
Posted Dec 16, 2019 - 11:19 EST
This incident affected: Personal Services (Personal Mobile App) and Business Services (Business Mobile App).