Quick Bill Pay for Personal Online

Incident Report for Hingham Institution for Savings

Resolved

This issue has been resolved.
Posted Jan 21, 2026 - 16:53 EST

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 16:41 EST

Update

Quick Bill Pay Update We’re still working to get the Home Page "Quick Bill Pay" shortcut back up and running. In the meantime, you can still access all features—including making payments and viewing history—by clicking Bill Pay in the top navigation bar. Thanks for your patience while we wrap this up!
Posted Jan 21, 2026 - 11:30 EST

Update

We continue to work on restoring the Quick Bill Pay feature on your Personal Online Home Page. Please note that full bill pay functionality remains available—simply click the Bill Pay link in the top-right navigation bar to process payments or view your history. We apologize for any inconvenience.
Posted Jan 21, 2026 - 09:58 EST

Investigating

We are working to restore access to the quick Bill Pay section available on the Home Page in Personal Online. Our Personal Online bill pay users can continue to pay bills and access their bill pay history by clicking on the Bill Pay link in the navigation bar at the top right. We apologize for the inconvenience and appreciate your patience while we work with our partners to restore service.
Posted Jan 21, 2026 - 08:16 EST
This incident affected: Personal Services (Bill Pay Services).