Debit Card Transaction Denials
Incident Report for Hingham Institution for Savings
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 14:15 EST
Investigating
We are aware of a processing issue that may cause certain debit card transactions to be declined in error. We are working to resolve this issue and apologize for the inconvenience.
Posted Feb 07, 2020 - 13:39 EST
This incident affected: Personal Services (HIFS Mastercard Debit Cards).