Personal and Business Online Banking and Mobile Apps

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Dec 01, 2024 - 13:14 EST

Investigating

We are experiencing an issue with our Personal and Business Online Banking services, including our mobile apps. We are working to restore service as quickly as possible and apologize for the inconvenience.
Posted Dec 01, 2024 - 12:36 EST
This incident affected: Personal Services (Personal Online Banking, Personal Mobile App) and Business Services (Business Online Banking, Business Mobile App).