Personal Mobile Application
Incident Report for Hingham Institution for Savings
Resolved
Access to our Personal Mobile Banking application as been restored
Posted Jul 20, 2024 - 19:01 EDT
Investigating
We are currently experiencing an issue with our Personal Mobile App that prevents customers from logging in. Our Business Mobile App, as well as Personal and Business Online Banking, appear unaffected at this time. While we are troubleshooting this issue, please use our web-based online banking for your banking needs. We apologize for the inconvenience.
Posted Jul 20, 2024 - 18:13 EDT
This incident affected: Personal Services (Personal Mobile App).