Online Account Opening

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Dec 12, 2024 - 11:02 EST

Investigating

We are currently experiencing an issue impacting customers attempting to open a new account from our website. Users may receive an error message or latency when attempting to open a new account. We are working with our partners to restore service as quickly as possible and apologize for the inconvenience
Posted Dec 12, 2024 - 10:28 EST
This incident affected: Personal Services (Digital Account Opening).