Business Online Banking Transaction History

Incident Report for Hingham Institution for Savings

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 12:08 EST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 11:44 EST

Update

We are continuing to investigate this issue.
Posted Nov 24, 2025 - 11:42 EST

Investigating

We are pleased to confirm that the service interruption affecting Retail Online and Business Online has been resolved. Users should now be able to successfully download transaction history within both Retail Online and Business Online. We apologize for any inconvenience this temporary service interruption may have caused and thank you for your patience.
Posted Nov 24, 2025 - 10:25 EST
This incident affected: Business Services (Business Online Banking).